Component Glyphs Preview Glitch

No Guides

As you can see in this photo, when viewing a glyph built from components the preview looks really weird and pixelated. If I decompose the component it fixes the glyph, but I use components a lot and would like to keep them. I also noticed that if I turned the guides on the preview went back to normal.

Also, one thing to note is that it exports perfectly fine. It’s only the preview that’s bugged.

I emailed glyphs and they told me to post it on the forum, so can anybody help?

It wouldn’t let me attach two images in that post but here is the preview when guides are turned on, looks completely normal.


Can you send me that file?

Yea sure, but I can’t upload it here because I am a new user. Can I have your email?

Send a link (dropbox or similar) in a direct message or send it to support at this domain.

Thanks for the file. It looks fine for me. Do you have any plugins in stalled?

I have a solid amount installed, but I also deleted a bunch, I’ll try deleting them all and re-installing.

Can you try starting Glyphs without plugins by holding the Option+Shift key when you start the app. So you don’t need to deinstalling them all.

I tried starting it with no plugins installed and it’s still glitched

Reinstalled Glyphs and it worked for a bit before glitching out again.