Component stacked diacritic alignment state is broken

G2.5b [1084] macOS 10.12.6
Bug, beginning with Build 1083
Building stacked component diacritics for Vietnamese, automatic alignment not needed. After being positioned and the file saved, then reopened, the top component diacritic has reverted to its original position.

Testing the same component pair of diacritics (circumflexcomb and hookabovecomb),

  1. Bottom (circumflex) component has automatic alignment disabled.
  2. Top (hookabovecomb) component has automatic alignment enabled.

Beginning testing with last build of 2.4.3, Build 1064

  1. In Build 1064, disabling automatic alignment and repositioning the top component and saving works as it should.
  2. Earliest build of 2.5b I have available, Build 1076, works as it should.
  3. Build 1082 works as it should.
  4. Build 1083 and later, both components show automatic alignment disabled and manifest the bug.

Other info:
The glyph I was testing,

  1. In Build 1082, shows the top component with automatic alignment enabled, bottom component disabled.
  2. In Build 1083 and later, the same top component shows automatic alignment disabled, and it cannot be changed unless the bottom component is first enabled.

Workaround using Build 1084:

  1. Enable automatic alignment on the bottom component, then Build 1084 will allow enabling automatic alignment of the top component.
  2. Do that, then disable automatic alignment for the top component. If you don’t first “enable” it for the top component, then “disable” it before you move it, the positioning change will not be saved.
  3. Move the top component to its desired position, then save and close the file. Upon reopening, the new position will be saved.
  4. Decompose the component diacritics. Positioning will be saved.

Or revert to using Build 1082 until the bug is fixed.

1 Like

Hey, bumping this up - I’m on version 3.0.5 (3131) - the issue is still happening:

brevecomb_tildecomb accent has a forced enable automatic alignment on the tildecomb component. Is that supposed to work this way?

Edit: the workaround does not work - only decomposing and manual adjustments is possible.


I fixed it.

1 Like

Seems to be sorted out! Thx Georg for your swift action! :star_struck: