Components ignoring anchors?

I’ve looked into using components like described in this tutorial, but the component does not seem to align with the anchor I’ve set up.

n with stem and “connect” anchor

picking my _part.shoulder

n with component inserted, also no “enable automatic alignment” in the context menu; the component is pasted in according to its LSB, so if I move the components path to x 20 and add it anew to the n it will be inserted at x 20

paths and “_connect” anchor in my shoulder component

What am I missing here? :slight_smile:

You cannot align paths with components. Make a purely compound glyph if you want to make use of automatic alignment.

Aaaaahh, yes. Thanks once again. Not sure if there’s any intuitive way of letting user know about this - maybe it’s just a piece of conceptual cake you have to eat once :slight_smile:

Sorry, but additional question here.

If I do enable automatic alignment to get the shoulder to align to the n using the anchor, like in the tutorial, then there is no way to overwrite the sidebearings, or use the combined sidebearings, is there? The whole anchor does not make sense if I either have to disable automatic alignment to set sidebearings (as future updates wouldn’t get reflected) or use unique stems with different width for very letter, since then I’d have to edit the stem components width to adjust the sidebearing in case the width of the shoulder changes?

Am I missing something more still? :confused:

There is a new way of connection components like this. Rename the connect to #exit and the _connect with #entry. Then enable automatic alignment for all components.

1 Like

Neat! That does the trick :thumbsup: