Constrain seems to be broken

OS X 10.5.8, Version 1.4.3 (581)

As the subject line says, Constrain appears to be broken.

[Edit]: But only when moving handles with the pointer tool. When initially drawing, it works.

[Edit 2]: Well, it just started working again. I’ll keep a watch on it.


I recommend to use Glyphs in 10.7+. The application can take advantage of some changes in the OS then.

My apologies! That should have read OS X 10.8.5.

I’m not that outdated, at least my software isn’t.

Phew :slight_smile:

Following up with this thread; it seems that Glyphs 2.3b (838) still does not keep constrain 90 degrees moves by choosing one node or the whole path; neither it keeps smooth constrain when moving Components (mostly with rough grids definitions).
is there a plan to fix it?

Constrained movement of paths and components works fine in 2.3b 845, can you update?

Weird !! I get update alerts frequently
Now it says you are up-to-date 2.3b (838)

Redownload the app from and run the updates again. That should fix the update process.

Again … Constrain (Shift-Drag) is not maintained in V. 873

Shift-Dragging works for me in 873. You cannot combine it with an additional key though, e.g., Alt-Shift-dragging.

It works only with Grid Spacing & Subdivision of (0:0)
While working on files of 1000 UPM I am unable to constrain movements when Grid is active (tested with different Grid combinations)

I tried what you said, but the constrain works for me, no matter which grid or UPM setting.

I’m sorry to keep on with this… you’ve evoked my suspicion that both SHIFT keys on my mac are not working!
eventually they’re fine. I will VSR and post in a few minutes.

It works fine with a grid of 1. Only above that it would not. I fixed it.

1 Like