Contextual alternates is "on" by default

At some point one of my fonts after installation has began to have Contextual alternates set to “on” by default. Meaning that even font preview in Finder shows the first and the last symbol in a line as of the “calt” feature is enabled.
When you, for example, open Illustrator and start typing a text there, to make it look “plain” you need to go to Open type panel and switch the calt feature off.

I’m using Glyphs 2 at the moment. Exporting font from Glyphs one does the same thing.

Any ideas how I can get back to “calt is off” by default?

This has nothing to do with the font, but what the app using it is set to do. The official UI recommendation is that calt should be on by default, so, Finder is doing it right.

Thank you, @mekkablue. What bothers me is that until a certain moment, both - Adobe apps and Finder displayed the font without “calt” enabled.