Continuous "syntax error" when trying to export


#1

I can’t figure out what is happening when trying to export my typeface here. I get a continuous version of the following error:

Error: "syntax error at "NULL" missing" in Feature ss02 in line: 21

The ss02 feature is automatically generated and there is no line 21. I’ve tried exporting with all Features turned off and I get the same error, with slight variations.

The generatefont.command accessed through the Details error gives me the following error:

makeotfGlyphs [WARNING] /BlueValues array too big (truncated) syntax error at "NULL" missing { GCLASS CID GNAME "]" } [features.fea 479]

Looking at that features.fea file at that line gives me:

@MMK_L_NULL = [ NULL ];

I have no idea what that’s referencing. My NULL character seems fine, and I don’t have a kerning pair of “L NULL”. The file was exporting fine recently, so not sure what I’ve done to mess things up.

I’ve also run through the Preflight Font script, and I’m only seeing errors on path directions, which I’m working to fix now.

Any help would be appreciated. And yes, I’ve Googled for every error I’ve found, read through all the articles and posts, and I’m still lost as to what my problem is.


#2

Simply delete that NULL glyph, and export again. (Or at least remove the kerning groups from it.)

The one in the mekkablue scripts? That one is outdated and has not been maintained in a long time, I am afraid.


#3

There were no kerning groups that included NULL, but deleting the glyph and adding it again fixed that error.

But… now I get this super fun and specific error.


#4

The message is incomplete, sorry about that. This is likely an incompatibility of the alignment zones (must be same number in all masters).


#5

I have fixed that. Will update soon.


#6

Fantastic. Thanks!