Copy from one instance to another

Hi. I made a new instance for my font, but I need that this new one has all glyphs from first instance. Is that possible? thanks

Do you mean you need to copy the outlines from one master to a new master? Mekkablue’s Copy Layer to Layer script may be useful.

1 Like

will try, thanks!

I was trying to copy outlines from one instance to another using @mekkablue script Copy Layers To Layers and I got this message at the macro panel >

Traceback (most recent call last):
  File "Copy Layer to", line 276, in <module>
  File "Copy Layer to", line 45, in __init__
    self.w.masterSource = vanilla.PopUpButton((120, 12+20, -15, 17), self.GetMasterNames("source"), sizeStyle='small', callback=self.MasterChangeCallback)
  File "Copy Layer to", line 117, in GetMasterNames
    thisFont = Glyphs.fonts[fontIndex]
  File "GlyphsApp/GlyphsApp/", line 1341, in __getitem__

Is the script outdated or something else?


The script needs a complete rewrite to run under OS X 10.12+; @mekkablue has it on his schedule. It will still run OK if you can boot using 10.11.6.

1 Like

I am using OS X 10.11.6 Capitan - still doesn’t work

Hmm. Last time I tried using it under 10.11.6 it worked OK but that’s been about six weeks ago. It may have something to do with your Glyphs version but only Georg or Mekkablue can answer that one.

The script needs a rewrite. For the time being, please use the Paste Special function.

1 Like

I didn’t managed to work using Paste special function. I tried by selecting a bunch of glyphs from one instance, switch to another instance, select the same glyphs and did the paste special and nothing actually happens. I am doing it wrong or this function did not work with multiple glyphs? thanks!

What exactly did you select in the edit view and what settings did you use in the Paste Special dialog?

Did you, perhaps, miss copying (Edit > Copy or Command-C) the glyphs before switching instances to attempt the paste special? (It wasn’t listed in the steps you did.)

No, at Edit view I can’t paste special, I’ve tried and the option it’s grayed out. I select a bunch from the Font View, copy them and switch to another instance, select the same glyphs then paste special, the window appear and I just leave it to Glyphs with same name and All data. The cells remains empty but with the unsaved grey tone… anyways no outlines pasted :frowning: Could you reproduce the same thing?

Can you send me a the file and screencast of what you are doing?
And what version of Glyphs do you have?

Here is a screencast and a zip file. Version 2.5.1 (1133) (2.8 KB)


“All Data” means that. I will make the glyph (not the layer) the same.
Instead use “Content of active Layer”.

Oh ok. Worked. I thought if you have all data, is all, included outlines… :slight_smile:

It includes outlines but it keeps the outlines in the layer where they came from and does not care what master is selected in the UI.

1 Like