Copy & Paste broken if format is stripped

For many years, I have been using a tool that allows to strip the text contents of the clipboard of their formatting, i.e. convert rich text to raw text. It is very helpful, and I don’t want to miss it. I guess I have it activated for about 50% of the time.

Since a few months ago, copying and pasting of contours in Glyphs is broken if the tool that strips the text formatting is active. They are usually pasted with a wrong size.

Maybe this could be fixed from Glyph’s end? Copy & paste within Glyphs worked perfectly for many years.


We discussed this and it seem it is an unfortunate side effect of the tool. I added a userdefaults to circumvent it:

Glyphs.defaults["GSCopyAsSVG"] = False

(will be in the next update)

Cool, thanks!

Is such a tool really necessary, Tim? Most mac apps have the Edit > Paste and Match Style command, which I use all the time and get the same result. But maybe it does not exist in some apps you use?

Unrelated to the actual topic, but I have been using Mac for roughly 16 years now and all the shortcuts or menu items that paste text without formatting or match the formatting have not worked for me. Not even once. So I can of get why people use apps like that :grimacing:

If you have a solution that works perfectly well, and consistently across all apps, then there is no advantage in changing it. The tool I am using (FormatMatch) hasn’t been updated since 2011, apparently, and it is still working flawlessly for me. That little Glyphs-related issue is the only small drawback, and it is solved now. Btw, in Excel, there is no quick way of pasting without format (Paste Special is powerful but very clumsy).