Copy Word Test Text script not working

I installed the above script (also the InDesign one), but when I run it and open the program to paste the assumed text, it doesn’t show up (same for InDesign). Am I missing something?

Using the latest app (v1265).


If there is an error, it should show up in the Macro Window.

This is what the Macro shows…

Traceback (most recent call last):
File “Copy Word Test”, line 25, in
copyString += currGlyph.glyphInfo.unicharString().replace(u"⁄",u" ⁄ ")
AttributeError: ‘NoneType’ object has no attribute ‘replace’

Not exactly sure how to diagnose/fix it.

Can you send me the font to res at this domain?

Sure, just sent it. Thanks for looking.

The script is choking on your .swsh letters, because they have PUA Unicode values. It works fine if you remove the PUAs (which they should not have in the first place).

I’ll try and catch the crash of the script. But the script may not (always) be able to put together the clipboard string for PUA-encoded glyphs.

That worked, thanks! Appreciate you diagnosing it.

(Yeah, the PUA encoding is something I’ve had to debate for certain fonts because there are some non-OpenType users who want access to the swash characters.)