Corner / Cap Components not working in Glyphs 3

Hi there, I downloaded the demo of Glyphs 3 before updating to it. I’m noticing the cap/corner components handle isn’t showing up in Glyphs 3 where it does in Glyphs 2. Any idea how I can edit it? If I hold down on the corner shape I get the info box, but as soon as I click it goes away, rendering it useless.

Attached are screenshots:

Glyphs 2

Glyphs 3

Double clicking to the transparent blue outlines (thicker ones) surrounding the corner shapes, maybe? (These are stands for Corner/Cap Components now, instead of the gray dots on G2, AFAIK)

You can select the corner shapes directly, now.

Hmmmm, I can click on it, when I hold my click down it looks as though its going to select it but as soon as I lift off the click it lets it go, so it’s impossible to actually select it this way. Am I missing something?

That happens to me too but only very rarely. Try to not move the mouse while you click. What kind of input device do you use?

It’s happening with both my mouse (Apple) and my Wacom Tablet. I restarted the program and can’t seem to get it work properly.

Happens to me all the time too. Cap/corner selection has become a real pain :slight_smile: Unless the shape is zoomed in to 100% or more, it take about 5-7 clicks before i can finally select it. :woman_shrugging:

Ah, yes, when I zoom out to 100% and click with my mouse then it works. Thanks for the tip! What a pain though, I hope this gets fixed soon.

1 Like

I fixed it. Thanks for the reminder.

I still can’t select it with my Wacom Tablet :tired_face:. Any ideas?

I just got a report that you can’t edit text fields with a Wacom in Font Info. Those drivers are very quirky how they send the events. I can’t really help with that. But does it work now with a mouse for you?

Yes it does most of the time (sometimes I need to zoom out and in to get it to work.) Just a pain to have to go back and forth between my pen and mouse, I’ll reach out to Wacom and see if they can update their driver.

I wish double clicking the cap/corner would insert the component – the same way double clicking a component does insert a component before the composite glyph…

1 Like

Sorry to wake this thread up but selecting corner/cap components is still a pain (for me at least). Sometimes it takes 5+ clicks to select a component, sometimes I need to zoom in/out too… No matter how still the mouse is, the selection lasts for a fraction of second and then disappear.
Wondering if it is possible to fix at all on either side - Glyphs or mine? Can magic mouse be the cause? (i don’t have a wired one so can’t test it).

Upd. After installing the latest beta (3062) it seems to be working much better. In the previous one it was still a pain…

Yes. We are aware. Looking for a better solution.

1 Like