Corrupt file questions

Yesterday, I saved a file with 5 masters, 21 instances and 2 axes, then quit Glyphs. When I reopened it, I got a message saying the file couldn’t be reopened. I assumed the file was corrupted. My last backup file was four days old.

Inexplicably, the corrupt Glyphs file would open just fine in FontLab VI. I ended up exporting UFO files from FontLab VI, then opening them in Glyphs. I had to recombine all the individual files into a new Glyphs file. Using my four-day-old backup, I recreated a few missing custom parameters, set up all the master and instances information, then corrected the path direction for all the masters.

Various other things, like glyph outlines themselves, kerning pairs, etc., seem to be OK. The file exports to OTF just fine and all seems to be good.

Never having had a need to do this before and no advice on what I was doing, I can’t help but think I’ve missed something important. Are their any gotchas I’ve overlooked that I probably ought to check?

The latest version of FontLab VI should be able to export a .glyphs file directly. The detour through UFO may be lossy.

1 Like

I had hoped that might be the case, but couldn’t find anything in the latest FontLab VI export options regarding it (below). Maybe I’ve missed something or looked in the wrong place.

I much prefer working in Glyphs to FontLab VI, but there are a few nice features in FontLab. A non-lossy way of transferring work between them would be fantastic.

The .glyphs export has to be enabled somewhere.

Can you send me the corrupt file? I like to see why Glyphs fails to open it and FL is still able to open it.

And instead of individual ufos, you could have exported an DesignSpace file. Then your relations between the masters and potentially the instances are preserved.


Thank you for the information Georg.

I’ve sent a zipped file to you. If you find the problem and fix it, would you mind sending a copy back to me?

It took only half an hour to find :slight_smile:
In FL6 you have to duplicate an export profile, or click Customise…
Then under Format Settings, in the right column next to Format, the text that absolutely does not look like a pop-up is actually a pop-up, which has Glyphs: Glyphs as last choice.

1 Like

And the bug and removed some invalid data from the file. So it can be opened again.

1 Like

Fantastic! Thank you, Georg. It’s much appreciated.

Thank you! I’m certain I would never have found that. It could hardly have been better hidden. It’s a good example, though, of one reason why I prefer using Glyphs over FL — the logical and intuitive user interface.