Could not generate as Variable font


#1

There a text appears as “Can’t convert to compatible TrueType curves.” “Glyph ‘dollar’ is not compatible”. I had tried several ways from the old forums but it still doesn’t work. My Glyphs version is up-to-date and I am using Mac OS High Sierra Version 10.13.6. Thank you for your answer


#2

Are you using the very latest beta version? Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.

Also make sure you have the Enforce Compatibility Check parameter in Font Info > Font.


#3

Thank you for a very quick response. 1. My version is already updated. 2.I could not find the Enforce Compatibilities Check" .


#4

If you click in New Parameter, and start typing Enf… it should autocomplete.

If it doesn’t, please verify the app build number again (Glyphs > About Glyphs): is it 1218?


#5

I already followed your instructions, tick the check-box, but still it appears the same error (attached photo)
18


#6

this is my ‘dollar’ glyph. there is a red line but I really don’t know how to get rid of it tho.

25


#7

Well, the glyph as it is now, is not compatible. Please read through this tutorial:
https://glyphsapp.com/tutorials/multiple-masters-part-2-keeping-your-outlines-compatible

And here on how to set up the bracket trick properly, because I assume this is what you want to do with the dollar:
https://glyphsapp.com/tutorials/alternating-glyph-shapes


#8

Hi Mekkablue,

Thank you for your help. I already did try using instruction you sent but then it still appeared the same error tho. I don’t know what did I do wrong about it.


#9

Please read the tutorial. You are trying to interpolate 3 outlines with one. That is not possible.