Crash loop with latest update 2.6.1 (1202)


I’m also crashing on launch after updating to the cutting edge version.

Have reported via Apple Problem Report.


1202 here also – NO crashes at all.


You don’t need to send the crash report to Apple. Please send the one that comes up when you restart the app.


Yep, that’s what I did. The UI screen name of that page is Problem Report for Glyphs.

‘Send to Apple’ is the action.


This report is not getting to us. Please have a look here:


I’m also in crashing loop on launch after updating to the latest version.
It doesn’t allow to send the Problem Report for Glyphs.


crashing for me also. i’m using 1201


This dialogue box isn’t showing up when trying to reopen.

I just tried opening with the plugins disabled which worked. So I will go through the list and let you know what is causing the issue.


Added the plugins back in one-by one and none of them worked.


We pulled 1202. Please switch back to 1201: Redownload from the Get App page and update to 1201.


Hi Mekka, I tried this last night, the same error occured when restarting with 1201.
So I have the dl version again and wait patiently for 1203. Don’t hurry, I’m fine with that.


Follow the steps in the Crashes tutorial (esp. deleting the files in your Library).


I think I found the crash. Can you please try version 1203?


thanks for the new beta, but it still crashes although I deleted those library files as Rainer suggested.
This is what would have been sent to Apple (the Glyphs dialogue box for sending a crash report to you never appeared because the app never launched again):
glyphs_crashreport_apple.pdf (186.2 KB)
I hope I can help you with this. Meanwhile I switch back to the 2.6 stable version, which works fine here.


Can you start the last stable version after the crash. It will pick up the crash and show the dialog.
But the crash log you send points to a plugin. Can you start 1203 with the Opt and Shift key pressed?


1203 is still crashing. I had that problem in 1201 so i guess that isn’t a problem in 1202.
It works when holding opt+shift though


That means it is a plug-in that is crashing Glyphs.


I just uploaded version 1204. That should finally fix this for good.


It works! thanks! :slight_smile:


Thank you, Georg!
It works fine with my Mojave machine in the office.
Let’s cross fingers that it will also do on the old Macbook at home. I will keep you informed.


On my old El Capitan book Glyphs tells me »Glyphs 2.6 is currently the newest version available.«
Is that because of my OS version or have you deleted the most recent betas again?