Crash on Export

I purchased Glyphs Mini and am trying to export a font I have edited slightly.

However the App crashes very time I try o export. No error message is given and the crash reporter also fails.

Any suggestions on what is causing this?

Can you try to disable “Production Names”, “Remove Overlap” and “Autohint”. Does this help? The update us submitted to Apple. I hope it is approved soon.

I’m afraid disabling those options didn’t work, I still get the crash.

hi georg,

i am facing the same problem.
unchecking the options mentioned above does not solve the problem.
it is a masterfile with around 800 glyphs. too many paths maybe?

would be great to have this issue solved because i want to test my fonts in real life.

What version do you have?

1.2.2, latest version.

hi there,

i reported this problem with files i try to export. whenever i do it, it crashes so i can not go on working on it, since i need to test it sometime.

georg, is there a chance to fix this problem int he near future?
i can also send you the file.


@facetype: Latest version is 1.3.6. I believe there was a problem with the built-in update mechanism in 1.2.2. Download the latest version manually and try again:

thx, mr blue.

hi, still not working, though at least no crash while exporting. i get this message everytime:

I have had problems with crashing on export in some of my fonts if I have been working with the file. But it works if I restart Glyphs, load the file, and immediately export.

The error message is about a error in the feature code. Can you go to Font Info > Features and click the circular arrow button and then the Compile button?

@georg: I’ve heard through other channels that facetype’s OT feature troubles are now resolved.
Everybody keep calm and carry on. :slight_smile:

@ georg @mekkablue
unfortunately not :-/
it does not crash anymore but still the fonts are not exported due to some feature problems, which is wicked since they are all compiled and generated automatically.

can you send me the .glyphs file?

I had a look at the file and the following glyphs have a comma in the left kerning class.
approxequal divide equal minus

if you remove the comma, it will work.


Glyphs crashes when I try to export font from a file that has two masters. Disabling the production names, remove overlap and autohinting didn’t help.

again, I need the .glyphs files to know what’s going on.


I sent you the file.

I tested the export on Lion and Snow Leopard. Glyphs seems to crash on export only on Lion