Crash when I close a font file


My Glyphs App still crash even if I hold the Option and Shift key when I start the app.

It’s happen mainly when I close a font file (I work on several versions of a font).

I work on Version 2.6.5 (1308)

crash (18.4 KB)



When you restart the app, do you get the Problem Report for Glyphs, like described in the Crashes tutorial? Please always send these by clicking on the button. The more the better.

The crash report you posted here indicates a memory management bug. I have been trying to reproduce it, but cannot. Are you using any system or memory optimizers on your Mac?

Hello! :slight_smile:

Yes, I get the Problem Report for Glyphs and I always send it!
I also saw the crash tutorial page;

I don’t use any system or memory optimizers on my Mac, but I use Little Snitch, Avast…

I suggest to uninstall antivirus software. It only makes your Mac go worse, and it does no good.

Is Little Snitch set to allow everything from Glyphs?

Ok I just uninstalled Avast and I restarted my Mac.

Yes, Little Snitch allow everything from Glyphs

But Glyphs still crashing…

  1. Can you make sure to disable Use Versions in the app preferences:


  1. The Crashes tutorial suggests to delete certain files. Can you do that, restart and try again?


Use versions is disable in the app preferences.

I tried all suggestions in the Crashes tutorial : latest cutting edge version , disable plug-ins, try with different document, delete the prefs, delete autosaves… And it still crashing :frowning:

  1. Can you try in a different user on your machine? Create a new user in System Preferences, switch to that user and try to reproduce the problem. If it is not crashing there, it has to do with something you installed or set in your user locally.
  2. Any other helper tools installed? CleanMyMac, MacKeeper, MacCleaner? Finder enhancements? Memory optimizers, defrag tools?

I tried to reproduce the bug in a different user and it seems there was not crashing there.

In my principal user session, I uninstalled CCleaner and Windscribe but nothing changed. And now I just uninstalled BlueStack, a Microsoft Windows emulator, and I try to reproduce the crash and nothing happen. It’s seems BlueStack was the problem.

Thanks you a lot

Thanks for reporting back. I do not know these apps. But good that you got rid of Avast and CCleaner, I do not think they can do any good.