Crash when trying to extrude multiple characters

Hi again !
I want to create a “shadow style” for my font as I said in that post.
I can apply the extrude filter to one glyph, and it works nicely.
If I try to apply it to all of my characters, Glyphs crashes, and I understand, it’s way too complex to deal with.
But with 50, or even only 20 characters, the app still crashes…
Did I do something wrong ?
(I don’t want to apply the filter one by one to the 300 glyphs of my fonts…)

What version of Glyphs do you have?
And did you send the crash reports (the ones that come up when you restart the app)?

I use the last one (3.0.1)
Sory I did not send the crash report (I was worrying that you’d receive hundreds of them every day…) so I’ve just tested again.
Now it doesn’t crash, but I have this error :

I applied the filter one letter after the other and I’ve just seen that the problem occurs only with a dozen of glyphs… For an unknown reason, the “objectAtIndexedSubscript” error still appears with those characters (some upper & lower cases, and some ligatures) even if I try to clean them up (Remove overlap, Correct path direction, Tidy up…)
Do you know what that error means, @GeorgSeifert ?

Can you send us (to support at this domain):

  • a .glyphs file with a few of those glyphs
  • the exact settings you are trying to use with the Extrude filter

Of course ! Thanks @mekkablue, I do it right now.
BTW I’ve just discovered in that post that we can add the extrude filter (is it the right name ? My french version says “Extrusion”) as a custom parameter to an instance.
So do Instances would be the best way to create this drop shadow effect ? (instead of applying manually the filter on a Master)

Hey guys. Still me :smiley:

I didn’t find any solution about my shadow style…
I tried using the Custom Parameter, but when I export my “Shadow” instance using Extrude , the app always crashes.

Here are my settings :

(I sent you the crash report too)

what version of Glyphs do you have (look for the four digit number (like 3042)?

3.0.1 (3039)

Can you try the latest cutting edge version (activate it in Preferences > Updates)

I’ve just installed it.
When exporting the shadow style, there’s an error saying that something went wrong with the RemoveOverlap filter on glyph “t_t°liga”.

It says the same if I try to apply the filter on that glyph from the pulldown menus in the preview window.
I tried to correct the direction path or Update Glyph info, or CleanUp the path… I still can’t apply the RemoveOverlap filter on that glyph…
What is wrong with this character ?

I ran into this same problem yesterday. Correcting path directions did not help, but I got it to work by selecting all and Reversing Contours.

Thank you very much !

I found the problem, @GeorgSeifert, it comes from the “Don’t substract” option :

If you set the Extrude custom parameter like this :
everything will be fine.

But if you put
the app crashes at the export.

So we can only make shadows without the substract option, which is too bad :slightly_frowning_face:

@GeorgSeifert Do you think you could fix that bug one day ?

Hi @GeorgSeifert, is there a chance that this bug would be fixed ?
I just need to know if I have to wait or if I make the extrude version manually.
I can’t accept to release the shadow style of the font without substracting the letter…

It works fine for me. Can you send me the file?

I’ve just sent it at the support email.


Hi @GeorgSeifert. Did you try with the file I’ve sent ?
Does it work for you ?

Thanks !