Crashes in El Capitan

I experience multiple crashes per hour in rather random intervals but always triggered by CMD+Z. Is this a known issue? Will it get fixed?

Make sure you always send the crash report. If you can reproduce it, it will be easier to fix.

Did you send crash reports (the one that shows up after you restart the app). And what version do you have?

Crashes from undo have mostly to do with something you did befor, even several minutes. Some plugins or scripts can cause this. Most problems in the app are fixed. It would be great if you could reproduce the crash and tell me about it.

I’ve send a couple reports last week i guess.
The most often it happens is when i’m very quick with my cmd+z after i made a change to something. I barely use any plugins and certainly not in the moment Glyphs crashes but i’ll try to uninstall everything else and run Glyphs clean for a time.

It has nothing to do with installed plugins, just the ones you use. What version do you use?

Georg, do you want us to send in the log for every crash? I’m only sending a few every day because I didn’t want to swamp you with lots of reports for the same bug.

The more the better.

Any improvements with the last El Capitan update (10.11.2) anyone?
I was reluctant to update it and still waiting for a stable version with less bugs.

I am very new to glyphs but mine seems to be running fine, though I installed it straight to el captain rather than updating to it.

Can you try the latest cutting edge version (activate it in Preferences > Updates).

Hi Georg,

My Glyphs version: 2.2.2 (825)
El Capitan 10.11.1
This is the window alert when I try to check if an update is available .

Perhaps see if there is a failed update in the App Support folder of Glyphs. If so, delete it, and try again.

I had already reported this to Georg via email a few days ago. It has happened before, possibly in a later v1.x build.

I tried several different things to fix it; none of them worked. Georg had to fix something on his end.

Best thing to do right now is to reinstall build [824] and wait for build [826] to be available.

I get the same error if I try to upgrade 2.2.2 (825). There is not a failed update in ~/Library/Application Support/Glyphs.


I solved this problem downloading the App again and upgrading it to the latest cutting edge.

Downloading (manually) and reinstalling was one of the things I tried, but it did not work for me. In my case, there is not a failed update in my app support folder.

My Glyphs keeps crashing a lot during a workday. Anyone experiencing this?
Just simple tasks, moving points. Crashes randomly. I’ve sent the reports. Hope there’s a fix.

There is a bug in MacOS that I can’t address. It crashed during autosave. But only on some machines. I reported it to Apple. Some time ago. Please keep sending the crash reports.

I’m not getting many crashes with El Capitan, but it seems like scripts run at least 10 times slower than they used to. One script I wrote, that never used to take more than a minute or so to run, now takes almost 20 minutes. (I don’t know exactly how fast it used to run because I never timed it before.)

I’m running Glyphs version 2.2.1 (819).

Can you send me the script. I’ll can check what takes so long.