Crashes when trying to re-interpolate

Hi there,

after installing the latest build (1320) today, I started experiencing crashes of the program when trying to re-interpolate a master layer.

3 masters on 1 axis; 2 of them (medial and maximum master) have outlines.

What I did:
I tried to “re-interpolate” (in fact extrapolate) the minimum master by using the “Re-Interpolate” function via the button next to the layers list.

Further testing:
When I filled all three layers manually, then created a bracket layer (for testing purposes) and tried to re-interpolate it’s content, I had the same issue (Glyphs crashing). The same happened with a brace layer.

I guess the bug was introduced in 1318, because in the changelog it states that “Re-interpolation of layers in smart components” was one of the topics worked on. However, I skipped 1318 when updating from 1313 to 1320.


Thank you for the detailed report, will look into it.

I ran into this yesterday, sent a few error reports with comments, had to revert to the stable release for now.

I fixed that.