Crtl + Alt + Arrow does not move nodes one unit at a time

Hi there,

I am bothered by the fact that when I try to move nodes using the Crtl + Alt + Arrow combo (to emulate FL’s Interpolated Nudge), the nodes are not moved one unit in each key strike. Sometimes they do but on other occasions they must be pressed twice.
Can it be fixed? It’s very bothering.


Can you send me a screen recoding of what you are doing?

Georg, it’s something very simple to reproduce. Just click a node on an curve, press CRTL + ALT and move the node with the arrow six times. Then check how many units the node was moved and it will be less than six. Why?

If I do that, it works as expected. You seem to do something different that I might stop when I see it.

OK, there you go. In the film you can see how some key strikes don’t move the node.


I experience the same thing.

1 Like

Can you send me the .glyphs file?

Georg, it happens with every single file.

Something has to be different.

Example file sent.

Run Font.keyboardIncrement = 1 in the macro window. That should fix it. I don’t know why this setting was wrong. I‘ll check it.

Cool! Now it works. Thanks!

Ah, that was the issue I was having too. I had changed the keyboard increment when I had a smaller grid subdivision and forgot to change it back. Thanks Georg!

I am curious, how did you changed the keyboard increment? Also by a Python command? I’ve no idea why mine was wrong.

Yes, with the same script mentioned above. I made this little script so I could toggle between 1 unit and 0.1 units when I needed finer control.

if Font.keyboardIncrement == 1:
    Font.keyboardIncrement = 0.1
	Font.keyboardIncrement = 1  	
print "Keyboard increment set to: "+str(Font.keyboardIncrement)
1 Like

@GeorgSeifert Every morning I must run the script again because otherwise the move increments are NOT of 1 unit. It only happens for the CTRL + ALT combination. Is there any way to make the 1 unit increment permanent?

I fixed it for the next update.
What version do you have?

Version 2.5b (1078)