Custom feature code error.... "lookupflag 0;"

Hi! I was trying to generate a Tamil font with custom code, but had an error.

The project generated just fine before I added kerning. After I opened the ufo in Robofont to tweak the spacing, and Metrics Machine for kerning, I brought it back into Glyphs and now it’s not generating.

I wrote the feature code using the features “akhn”, “psts”, and “dlig”. I haven’t used Glyphs much ( :flushed: ) so I am not sure how the marks/kerning features are automatically generated.

I pressed the compile button and had no errors, but after looking at the generateFont.command output, it looks like the error happens where a lookupflag 0; is automatically inserted after the kerning classes are named, and right before the “dist” (kern) feature.

here’s the error:

makeotfGlyphs [FATAL] <HuntTamil-Regular> expecting EOF (text was "lookupflag") [features.fea 195]

and here’s the area where it occurs:

@MMK_R_roundtamil = [ e-tamil ee-tamil o-tamil oo-tamil au-tamil nna-tamil nnna-tamil la-tamil lla-tamil va-tamil ssa-tamil sa-tamil ha-tamil om-tamil k_ssa_uMatra-tamil k_ssa_uuMatra-tamil nya_uMatra-tamil nya_uuMatra-tamil nna_iMatra-tamil nna_iiMatra-tamil nna_uMatra-tamil nna_uuMatra-tamil nnna_iMatra-tamil nnna_iiMatra-tamil nnna_uMatra-tamil nnna_uuMatra-tamil la_iMatra-tamil la_iiMatra-tamil la_uMatra-tamil la_uuMatra-tamil lla_iMatra-tamil lla_iiMatra-tamil lla_uMatra-tamil lla_uuMatra-tamil va_iMatra-tamil va_iiMatra-tamil va_uMatra-tamil va_uuMatra-tamil ssa_iMatra-tamil ssa_iiMatra-tamil ssa_uMatra-tamil ssa_uuMatra-tamil sa_iMatra-tamil sa_iiMatra-tamil sa_uMatra-tamil sa_uuMatra-tamil ha_iMatra-tamil ha_iiMatra-tamil ha_uMatra-tamil ha_uuMatra-tamil day-tamil credit-tamil aiMatra-tamil aulengthmark-tamil ];
lookupflag 0;

feature dist {
lookup dist_tamil {
	lookupflag IgnoreMarks;
	pos @MMK_L_concavetamil @MMK_R_atamil -50;
	pos @MMK_L_concavetamil @MMK_R_roundtamil -25;
	pos @MMK_L_concavetamil @MMK_R_katamil -35;
} dist_tamil;
} dist;

Can someone reading please tell me what I should do to make this work, and why this is breaking? :slight_smile: Thanks so much!

What version of Glyphs do you have? Could you send me the .glyphs file?
Do you have any kerning between any none Indic glyphs? Can you try to add some?

Version 2.4.2 Just sent the file to
Actually there are only Indic glyphs in the font right now, but I could add a kern to the space character or make punctuation.


Weird, when I changed the name of the .ufo and reopened it, it automatically took away the closing brackets of my features and moved them into additional “Languagesystems” prefix.

I also tried kerning a tamil glyph against the .notdef and got the same error.


didn’t have any latin glyphs in the font, just added this because Georg asked

Also, I’m not married to the feature code I wrote - if the Glyphs code does the same things (which I believe it would), I could just use that instead. But I tried to delete my features and use the auto-generated Tamil code and still had issues generating.