Custom parameter for exports issue


It seems that with the latest two updates something with the exporter isn’t working correctly. I believe it has to do with the custom parameters in the exports which are not being read.

For instance, when working on a color font, only the first palette is read, not the one specifically assigned in the custom parameter. Also, when transforming my COLR layers to an SVG export, it remains a COLR version.

Something else could be the cause, but these were my (quick!) findings. Let me know if you need some more info.

(it also seems the import one master from a file into another isn’t working for me, or at least the popup isn’t showing up).

Can you send me your file?

I also found that some custom parameters were not evaluated (Keep overlapping components, Remove glyphs). Only after I unchecked and checked again their active status, they are applied. Maybe related?

Checking/unchecking solved it, thanks!

For the merge: This doesn’t work with any file (from the masters > + add other font dropdown). Perhaps I can use another method?

I can’t reproduce this.

The checking-unchecking seemed to have worked for all, even with files which previously didn’t export, so no idea what caused it.

The master>add font is’s working for any font, there is no popup showing. It does work in G2. Running Mojave, perhaps that’s the cause?

It may not be the check/uncheck thing, but any change to the custom parameters that triggers them to be applied correctly again.

E.g. when I export the fonts (TTF in this case) from sudo-font/Sudo.glyphs at e6967f032a85fb936724f78cef9fc1811e52dce0 · jenskutilek/sudo-font · GitHub, the .ss20 glyphs stay in the font even though they should be removed per CP. When I change anything in the “exports” CP, e.g. Uncheck the “Keep Overlapping Components” box, and export again, suddenly the .ss20 glyphs are not in the exported font anymore.

This applies per font, so I need to trigger a change in each defined export.

I fixed it.

1 Like