Custom parameter Remove Features doesn’t include kern


#1

If I have added the kern feature manually (for instance for a Contextual Kerning Lookup), and I add the custom parameter Remove Features (and include the kern feature), it seems not to work. Is this correct? Is there a way to remove all features including the manually set kern feature?


#2

That is the one thing you cannot remove (yet) with this parameter.


#3

Fixed it.


#4

Are you sure? Still reporting error when generating (latest Glyphs 854).


#5

It seems that an error occurs when custom parameter Remove Feature kern is in the font and parameter Remove Glyphs containing glyphs that are actually in the manually added kern feature.


#6

Fixed it again.


#7

Seems that in 856 it’s not working again.


#8

It seems that it’s still not working. I’m using version 875. I have a Remove Feature kern parameter and a Remove Glyphs parameter. Remove Glyphs contains a glyph that is in the manually added kern feature.


#9

fixed that.


#10

It removes the entire kerning, right? What, if I just want to remove the manually added kerning?


#11

That is an interesting question.