Custom Woff2 emoji unicode glyphs not displaying in Chrome

I’ve created a Woff2 web font that uses several custom glyphs that point to unicodes used for emoji. These custom glyphs correctly display in the TTF export when viewed in FontBook, Sketch and Illustrator, but when using this font on the web (viewing in Chrome for Mac) the system emoji glyphs are used.

Can anyone offer a suggestion as to what I may be doing wrong?

How are you testing the font?

It’s being declared via @font-face. Some glyphs are working correctly, but others don’t display, as if they haven’t been exported as part of the Woff2 format.

Are you exporting an interpolation? Did you check compatibility? Path direction? Subsetting?

What happens if you put the .ttf in the @font-face?

Same thing happens, which suggests it’s an export problem.

This is a comparison of a successful (6) and unsuccessful (7) glyph. The Unicode information is missing.

“6”: {
“name”: “uni2764”,
“unicode”: 10084,
“unicodes”: [10084],
“advanceWidth”: 742,
},
“7”: {
“name”: “U2715”,
“unicodes”: [],
“advanceWidth”: 600,
},

Can you point me in the right direction? Thanks in advance.

Stick to the naming convention. Call it uniXXXX for 4-digit hexcodes, or uXXXXX for 5-digit codes. E.g., uni2715 or u10023.

If you do not want to employ this convention, check File > Font Info > Other Settings > Use Custom Naming and proceed to set the Unicode values manually.

That did the trick. Thanks for your help!