Cyrillic help (Й won't work)

I’ve made a basic cyrillic character set for my most recent font project, using the Languages > Cyrillic > Basic filter in Glyphs. It works pretty well, except that the glyph named “ShortI-cy” is sorted under “Other” rather than “Letter, cyrillic” in the glyph inventory window. Typing “Й” will not produce that glyph, neither within Glyphs nor when using the exported OTF file.

What is the correct glyph name for “Й” inside Glyphs?

Also, I’m not actually a user of the cyrillic alphabet. Is there a native reader of cyrillic on this forum who would like to check my font for legibility and point out other things I might have missed? I’ll throw in a free font license.


Oh, got it. I tried “Ishort-cy”, and that got sorted right. Consider this a bug report, then.

Some people offer professional Cyrillic services, amongst whom Alexei Vanyashin:

On his website, you’ll find a beginner’s guide to Cyrillic. If you want commentary for free, you can post screenshots here or on one of the other type forums.

@mekkablue there was a bug in the glyphdata file.

Oh, sorry for the misunderstanding, I should have specified I was only responding to the second question, the one about Cyrillic design critique.

Here are the provisional shapes for my Cyrillic blackletter:

And here’s a thread on Typophile in which a discussion has started on the topic:

A similar problem: The Adobe Extended filter generates glyphs named “Chedescender-cy” and “chedescender-cy”, but they get sorted under “Other”. I guess that’s another naming convention mismatch? The name looks sensible this time, though, and I haven’t found a name yet that will get sorted into Letter, Cyrillic.

I’ve checked, and the characters called “Chedescender-cy” and “chedescender-cy” do in fact not work in the OTF version of my font. What’s the correct name for those characters?

If you know the Unicode, you can search for it in Window > Glyph Info.

@cthalmann They are correct. Do they have a unicode assigned? Select them and click Font > Update Glyph Info.

They do not have a unicode, and Update Glyph Info does not change that.


what version do you have?

Works fine for me.
Did you disable nice names in Font Info > Other Settings?
Which version are you running?

Switching to the newest version and updating the glyph info worked. Thanks!