Deactivate Remove Overlap Filter


Is it possible to deactivate Remove Overlap Filter for a certain glyph?
I’m trying to export some webfonts with Glyphs Project but I’m getting this error.

I think the reason is because there are too many points on the same glyph and/or it’s a too large glyphs when exporting with 2048 UPM.

The problem is that Adobe’s Remove Overlap code (which is implemented here) can only handle point coordinates up to ±8191. You can try and break it into two glyphs, and have an OT Feature split a into a.firstHalf and a.secondHalf.

Yes, I know. That’s why I wanted to deactivate ‘Remove Overlap’ for 1 character or even for the entire font. In this case, it’s just a one weight font (the master) with just 30 characters, so I can remove overlap of everything directly on the file before export.

But I will also think about your suggestion.

You can add a “RemoveOverlap” filter to your instances and add excludeGlyphs:a to it. And then disable the Remove Overlap in the export dialog.

1 Like

That seems to work for otf. But there’s no ‘Remove Overlap’ button on webfonts export dialog (and glyphs project), right?

Yes. There is no option for that. I’ll see what I can do.

That is fixed in an upcoming version. For now please convert your OTF with an external tool.


Great! Thanks for the collaboration guys. :raised_hands:

Guys I’m trying this Remove Overlap filter in another project, but it’s not working as expected.
The remove overlap is ok, but it’s not excluding the glyph I want.
Maybe something is wrong in my parameter. Can you help me?


Did you uncheck the box in the export settings?
It should be exclude: and not excludeGlyphs:.

Thanks, I will try it tomorrow with just exclude: ! I want to exclude 2 glyphs. How exactly should I write it Georg? RemoveOverlap; exclude:percent perthousand; (any comma inside?)

I think it worked fine!