Dekink after Export with RMX unsuccessful

Hi Forum!

I’m making a multiple master rounded font and I wanted to apply the dekink parameter in RMX Tools but the shape seems to stay broken even after export. At first I copied the parameter from the RMX interface, but instead of copying just the parameter, glyphs copies the following:

		Filter = "RMXHarmonizer;supersmooth all";

G3 wouldn’t recognise this, so I got rid of the extra stuff and left RMXHarmonizer;supersmooth all

Still, no visible effect after export, here’s a picture of the kinks:

Am I forgetting or overlooking something?

Thanks in advance for your time!

Make sure the joining points are smooth points and that there are no nearly overlapping points. Run Tidy Up Curves first.


Thanks for your reply! The overlapping nodes were the issue, now it works :slight_smile:

1 Like

Back to square one, worked for a moment but now it doesn’t anymore. I’ve checked all nodes are smooth and there are no overlapping points.
Here are the two letters and the interpolation:

Any suggestion?

I don’t know what your expectations are for the software. We all still have to do the drawing and fitting.

1 Like

I’m not expecting anything outside its core functionality, which is evening out green nodes handles after export. :sweat_smile: As I said it worked before and I’m just having issues replicating that scenario (even though nothing has changed in font info, afaik), I’m perfectly aware that drawing quality is key, but in this design I can’t go for the same angle/same proportion rule, thus this filter is crucial. :slight_smile:

In case someone stumbles across this, the answer is here:

1 Like

Link returns:

Oops! That page doesn’t exist or is private.

1 Like

I have found a way to circumvent the problem:
Glyphs converts the smooth nodes in corner ones after removing overlaps, so just untick the remove overlap box at export and apply it as a custom parameter. You’ll need some adjustments in the font but it works.