Descenders cut off in OSX apps and more

Like this:

Also problem with underline in darker weights:

Thin master metrics:
Ascender: 737 (+10 alignment zone)
Descender: -220 (-10)

Ascender: 766 (+12)
Descender: -230 (-12)

I also have these parameters in both masters, due to double line gap problem from the past:
hheaAscender = 780;
hheaDescender = “-220”;
hheaLineGap = 100;
TypoAscender = 780;
TypoDescender = 220;
TypoLineGap = 220;
winAscent = 800;
winDescent = 200;

Font’s U/Em is set to 1000, but Black master exceeds that with alignment zones added in. Is that the problem? Blog post on vertical metrics mentions openTypeOS2Ascender, but there’s no such parameter in the app, openTypeOS2TypoAscender seems to be the closest.
As for underline, I’ve tried adding postscriptUnderlineThickness and UnderlinePosition parameters to masters, but they changed nothing.

P.S. How do I embed images with “image link”? Tried everything.

Just drag the image in the glyph or use Layer > Add Image?

I mean here, in the forum posts :slight_smile:

when selected

I’ve scaled the font to fit into 1000 and set the parameters with the help of this guide
But there’s still some of descender that’s cut off and whole font sits at the bottom of the blinking cursor.

And it looks like that pictures won’t show up if there’s no description.

Are there any elements that stick out over the ascender hight?

Rewrote for clarity:

If you mean beyond “font info” ascender, then letters with alignment zones and and occasional diacritic extend beyond. But for parameters I’ve added extra space and rounded the values so that optimum a+d=1000.
For maximums I used the tallest/lowest glyphs, like: Ǚ and ț.

Current thin master metrics:
Ascender: 700
Descender: -210

Ascender: 730
Descender: -220

Extreme glyphs (Black): 1100/-240

openTypeOS2TypoAscender = 700;
openTypeOS2TypoDescender = 300;
openTypeOS2TypoLineGap = 340;
openTypeOS2WinAscent = 1100;
openTypeOS2WinDescent = 240;
openTypeHheaAscender = 1100;
openTypeHheaDescender = “-240”;
openTypeHheaLineGap = 0;

P.S. Typo values are 700/300 and not 750/250 because I tried to “lift” the line but it didn’t change.

I deleted Font Info parameters, used Masters’ ones instead and it works. So now I’m confused. Which one Blog tutorial had in mind when each tabs use different names for same components and none of them match the tutorial.

I change the parameter names to be better readable. I removed the suffixes. So now you can use “TypoAscender” or “openTypeOS2TypoAscender”. Both work. The drop down will only offer the short version.

So you mean that if you put the parameters in the custom parameters of the font it did not work? You should note that if the key is drawn in gray, it will not be used.