"description" string is empty

Hi there, working in glyphs mini. Imported some letters from a program called fontstruct and worked on it a bit in glyphs. Now when I try to export my file it’s giving me this pop-up. I have a feeling it’s something in the code that needs to be addressed but I don’t know how to access that. Any help would be appreciated, thanks.

Can you please send me the .glyphs file to support (at) (this website without www). I will have a look.


Fontstruct probably added a description parameter to the export. Mini should ignore the description but does not. Here is what you can do:

  1. Save and close the .glyphs file in Glyphs Mini.

  2. Open the .glyphs file in a plaintext editor, such as Atom, SublimeText, TextMate, BBEdit, or the likes. (NOT text processors like Word or Pages.)

  3. Select and remove the following 4 lines towards the beginning of the file:

  4. Save the file and quit the text editor.

  5. Reopen in Glyphs Mini, and export again.

Sorry for the inconvenience.

October, 2021, and this bug hasn’t been solved yet: An error message leads to a field on the “info” panel that does not exist.