Diacritics displaced

Hi there,
not sure exactly what’s wrong with my Glyphs file, but my diacritics don’t want to snap to the anchors. In this screenshot here I’ve set the anchor both in the macron and in the A and it should be working fine. But you can see the Amacron result on the far right. Can anyone tell me what’s up?


Automatic Alignment disabled?

Go to File > Font Info > Other Settings and make sure Automatic Alignment is not disabled. Then, go into Amacron and choose Layers > Make Component Glyph. In G2, this command is in the Glyph menu.

Perfect! I didn’t know about this feature as it has never been automatically off like that. Must have had something to do with the export from FontLab. Thanks a lot!

FontLab does not have automatic alignment. That is why the Export macro warns you about it: