Diacritics not working on Windows


Im using Glyphs app 2.4.

Everything seems to be fine when the font is installed on MAC, but on Wind0ws non of the Diacritics are showing at all. The sub categories in the glyphs table are all visible (Basic Latin/Latin 1, Extended Latin A and Extended Latin B) but the Diacritics have disappeared.

One thing that i know i haven’t done correctly is labelled the combining marks with .case, instead i have just corrected the positing. Seeing that it is an all caps font, could this have caused the issue?

I have also tried decomposing the Diacritics before export but that hasn’t worked.

Any help would be great.


They are likely being clipped off. Have you read this tutorial? --> https://www.glyphsapp.com/tutorials/vertical-metrics

Hi George, thanks for the reply.

Ive checked the metrics and its all in order.

I believe the problem is with one of the custom parameters i set in the font info. Im expanding on a preexisting font without diacritics so i added to the unicodeRanges and glyph order to the parameters that were already in place. I deleted the changes that i made and everything seems to be working fine now.

But now the font info is incomplete with the expanded diacritic support I have added. Is this going to create more problems with compatibility if i just leave it?


Do you mean you added some glyphs to a font?
You can remove the ‘glyphOrder’ and ‘Unicode range’ parameter. Both will be generated automatically.

I don’t think i did a great job of explaining myself in my opening post. My fault.

Either way, i was running into the issue of some diacritics exporting for mac and not for windows (and vice versa) when i was adding custom parameters for unicodeRanges and glyphOrder. The only evidence i have to back this up is when i deleted those parameters, the problem resolved itself.