Differences between kerning in Adobe Creative Suite and Word


#1

After exporting the file, either otf or ttf, the font seems to work fine in Illustrator or InDesign, though there are updates to the kerning which do not come through in Word or Powerpoint - where the client will be using the font.

I have tried clearing any cache issues as per 2.10.6 of the Glyphs Handbook, and have moved to Suitcase Fusion 5 instead of Font Book.

Please help!


Kerning and Features not working in Word 2010
#2

Please read this:
https://forum.glyphsapp.com/t/kerning-problem-in-microsoft-office/


#3

Hi, thanks for your response. I still can’t seem to resolve the issue by the feedback which was supplied in this post (there was a broken link which may have been essential).

The letters have Unicodes so I’m not quite sure where I’m going wrong - what do you suggest for next steps to fix this?

Thanks


#4

Which Word are you talking about? For the Mac? Perhaps this is a font cache problem. Read this please:
http://www.glyphsapp.com/tutorials/eliminating-font-cache-problems


#5

Thank you. We have tried Word for Mac (2011) and PC (2010).

Have tried the cache troubleshooting with no luck so far. The problem comes up when installing the font on colleagues’ computers for the first time as well.

I have emailed a copy of the working file to your info@ address, would there be a chance for you to have a look at this file if possible please?

Thank you very much


#6

I had a look at the font and couldn’t find the problem, yet. I don’t have more time right now. I’ll try later.


#7

Ok great, thank you very much.
That would be really helpful.


#8

I am afraid we could not get the font’s kerning to show in Word.

I assume it has to do with the poor outline quality currently present in the font, because the kerning does work if I delete all off-curve points.

How did you generate the curves? Perhaps read this:
https://www.glyphsapp.com/tutorials/drawing-good-paths/


#9

I am experiencing this issue with Word 2011 and Word 2015.

My font looks unkerned but when I activate kerning from Format > Font > Advanced > Kerning for fonts, it looks fine. Is that how it is supposed to work?

I read these articles:


Since the kerning is off (as it appears) by default, would TimAhrens suggestion to assign PUA’s to unencoded kerned glyphs make any difference? Should I not bother about this or is there a way to make the font have kerning on by default?

This is an image from Word 2011. The text on the top is default and the one below is with the kerning activated.


#10

DTF’s post said it best. MS should make better software – but one has to realize their software is aimed at the business user, not the graphic arts user. The one program they have (Publisher) that is supposed to be for graphic artists and printers is a cheap, low-end piece of trash.

That being said, there is nothing you can do to your font to force Word to work better. It is all up to the app.


#11

Yes. This is how it works in Word. I do agree it should be on by default.


#12

Thanks for letting me know. Pity for MS, but then I wouldn’t expect something to actually work right in their software.


#13

Hi! My font has this kerning problem. I already red the other threads regarding this topic and I made sure it is not a cache problem. I thought it might be the unicode value problem (Kerning Issue in Microsoft Office 2011) so I made a test font without the respective glyphs.

I am using Word for Mac 2016. Activating the kerning in the Advanced Font Settings activates the kerning for other fonts, but not for mine.

Now, how do I fix this? I can’t find any source of the problem in the glyphs or font file.


#14

Can you please send me the .glyphs file to support (at) (this website without www). I will have a look.


#15

I had a look at the font you sent me, and it works as expected for me in Word for Mac 16.25 on Mojave 10.14.5. Did you make sure to activate kerning for the right font size?