Dimensions Window (BUG) v2.5.2 (1150)

The Dimensions window opens existing files with no data, all masters display blank. If you try to enter dimensions to one master layer, they are applied to all masters (2 in my file). Before testing any further I reverted to using Glyphs 2.5.2 (1149) and my dimensions were restored with the changes made to glyphs made in the brief use of v1150 still intact.

They are not applied to all masters. The text field are simply not updated at all. There is a bug that seems to be related with changes in macOS that breaks the loading of the UI. This would crash a lot so instead of crashing it is not functional at the moment.
Does restarting Glyphs/your Mac solve the problem?

Thanks Georg,
I just restarted the Mac and the dimensions are still blank in v.1150, I can type in the empty fields and nothing saves – thanks for your prompt reply.

Still blank for me Version 2.5.2 (1150)

I can reproduce too. I think it’s a bug in the latest version (1150). It works well with the (1149).

Same here, all dimensions have disappeared in all glyph files (Version 2.5.2 [1150]) on mac. Hope this is fixed soon.


I had another look and could circumvent the problem.

I just uploaded a new version that should fix this.

Works, thanks!

It worked! (1153) Thanks.

What is the place to download 1150? When tried ‘Check for Updates’, got only 2.5.1 (1141). Im losing dimensions data and all guidelines by closing document.

Installed cutting edge 1173, but still have same problem. When closing an existing document (created originally with other software), all data stored on different layers will disappear after reopening — background, image, guides, dimensions, smart object properties, which all are added here. But seems, it is connected with the document itself. When creating new document, draw there some forms on different layers and add guides, they will remain!

But I exported a document as OTF and opened it again. Now the data holds.

Can you send me the file that looses data?

Oh, stupid me! As the file was after exporting from FL in UFO-format and Glyphs continued to save it by default in UFO, this was te reason of losing guides, dimensions etc. After I saved the document into Glyphs format, is everything well.

1 Like