Disable automatic alignment not working


I am working on a file and usually disable automatic alignment works, but I’m not sure if its the update or what but it won’t work, yesterday, when I would click enable then disable would appear and I just click it and it works, now it will only enable automatic alignment.

is it a bug?? or how can I resolve this

It is a bug in the UI. As a workaround, you can use the mekkablue script Components > Alignment Manager.

1 Like

What version of Glyphs do you have?

its glyphs 3 and its updated two days ago

That worked! thank you!

Where is the “Disable Alignment” setting found? I tried Control click

Directly click on the component.

1 Like

Thanks, Georg!

The only way its been working for me is the mekkablue script. even when its clicked

Have you tried the latest cutting edge version?

Yes, my glyphs is up to date and I quit and shut down my computer and everything it for some reason will not reappear as an option. not sure if its a bug or what.

Can you send me that file? And in what glyphs does this happen?

1 Like

Sure. its glyphs 3 actually. and its happening in two files

  • Set Font info > Other > File Format to version 3
  • Make sure you have the latest beta, I cannot reproduce the alignment issues in 3.1 (3132) anymore.