Disable background snap?


#1

I’ve got a font file with very rough outline of which I need to create a much simpler one. I think the best way is to put the original in the background and trace it, but “snapping to background outline” feature gets in the way.

Could you have an option to en/disable snapping to background? In fact, while we’re at it, have options for different kind of snapping (guideline, measurement line, etc)?


Disable Background/Point Snapping while still keeping Shift dragging?
#2

I sent you an e-mail with the geek solution to your problem: a .glyphsReporter plugin that just displays the background.


#3

I’m curious about this tool too please and I think an option to disable enable snapping to background and other snapping would be great…


#4

+1 to this request.

I have used the Pencil tool to ‘sketch’ in a rough outline of my letter, and sent it to the background. As I attempt to trace over it, holding shift to constrain handles to 0/90° becomes very difficult, as the snapping stumbles over the multiple lines I’ve drawn in the background.


#5

I sent you a plug-in via e-mail. Let me know how it works for you. I will put it in the Plugin Manager when you think it is OK.


#6

Thanks for sending that!

I installed it (Version 2.5b (1093)), and handles are still snapping to points in the background. Also the background displays with a fill preview, instead of the usual outline, not sure if this was your intention.


#7

It would be nice anyway to have a way to disable all snapping globally. For some very irregular fonts, it just doesn’t make sense, not even the suggestion of node positions relative to other nodes on the same layer.


#8

Ah, OK, I guess this is something that cannot be disabled as easily. I’ll file it as feature request.


#9

Cheers @mekkablue


#10

Sometimes, when I shift parts of a contour by dragging with the mouse, I can see red lines flashing, and I cannot place things where I would like to. As if some other sort of snapping, similar to Illustrator’s “Smart Guides”, is happening. It seems unrelated to the background.

Is this an undocumented feature? How can I turn it off? It can be very annoying.


#11

You can temporarily hold down the Ctrl key. Red lines will still show up but will not cause snapping. And there was a pref you can use for turning it off globally… I’ll dig it up, just a moment. Edit: Could not find it, maybe I remembered it wrong, sorry.