Disable hidden path forming a loop?

This has probably been asked somewhere already but I couldn’t find the answer. Is there a way to disable the smart hidden path behaviour (for a glyph or enven better for a bunch of selected nodes)?
image image

Can you be more specific what you mean?

1 Like

I would like to be able to desactivate the function that hiddes corner paths (i don’t know how to call them, the picture is probably clearer). The reason why i would like to do that is because i m drawing using a central path (not outlines).

Maybe this helps?

1 Like

Amazing, that’s exactly what i was looking for! Thanks

To my surprise this is actually not working… :confused:
I tried a few times, restarted Glyphs, moved points to force the update, but when using the preview (space bar), the part of the path after the crossing is still not being rendered.
It’s probably because the path I’m using is not a contour overlapping anything but a central path I’m applying a stroke to.

Is there a function to disable this smart behaviour?

Can you post a screenshot of the full outline?

Preview (no outline applied)


That is an external self inflection. In this case, changing path direction would help.

Removing those overlaps doesn’t make much sense on open paths, I’ll disable that.

1 Like

Changing path direction made it, thanks a lot!

Final thing: Reversing the direction only works if the loop goes in one direction. In the case of a right-left then left-right crossing (on the same path), one will be hidden (depending on the direction of the path).

I know. That’s why I said ‘in this case’ :wink:

1 Like