"Disable Localization" does not work

In Version 2.1.1 (804) the disable localization function does not work. I have the box checked and Glyphs restarted, but all the menues are still in german language.

Ivan S.

Then there is something wrong with the file permissions of you Preferences. I didn’t change anything and it works fine for me.

Okay, got it fixed. I have changed the primary language in the “language & region” section of the OS system settings from german to english, restart and then change everything back. Now running the same settings as before, but the “disable localization” function works.