Display Error in Fontbook with Icon Font

Hi there!

im new to Glyphs and have a question / bug report:

after exporting an iconfont to .otf with the usual settings ( i did an export in the trial version earlier and it worked great ), ig to the following error message:

https://www.dropbox.com/s/rfjhdisjx624yyo/Error.png

After the error message i changed the export options to:
(basically i unchecked the outline-option)

https://www.dropbox.com/s/wtd7nsdjbro3g4q/Settings%20after%20Error.png

Then i exported it and thought - okay fine! But now the font is all messed up in the fontbook.

Its like the icons now have a huge white-space around them - i dont know how to get it gone!

it looks like this:
https://www.dropbox.com/s/qp51s63y1vny9gg/Glphys%20in%20Fontbook.png

The other font which i did with the same settings for the font and export options looks like this (how it should be):

https://www.dropbox.com/s/qp51s63y1vny9gg/Glphys%20in%20Fontbook.png

i dont know if this problem has deen resolved somewhere allready…

Can you help me?

-Cheers,
Jan

The to screenshots from FontBook are the same.

Did you download a new version after buying the license?

And how do you install the fonts for testing?
Please read these:
http://www.glyphsapp.com/tutorials/tag/testing

Hey there,

The second link was wrong, sorry about that:

https://www.dropbox.com/s/mn2811tirgj0i55/how%20it%20should%20be.png

  • i tried cleaning the font cache - to no help.

The Font works great, just as expected - but it appears completely wrong in the font book.

Did you make sure there were no conflicting fonts?
You can send the .glyphs file to support at this domain.

Hey there,
i think i found the problem - it was with the used icons.

Thanks for all your help though!