Display of Images in Font Window

If I disable ›Show Image‹ in font window nothing happens (images are still visible).
To hide images, I have to switch to another tab and then go back to font window.
[Glyphs Version 2.2.2 (827)]

Additionally, it would be great, if Glyphs would store the show/hide-image-setting on a per window basis.

I generally would prefer images not to be shown in font window and to be shown in edit windows. As of now this is not possible without changing the setting all the time.

The setting only affects glyphs containing paths.


Would not make sense for .phf and sbix fonts.

For me it works in the following way:

In edit windows it works as you say: As soon as a glyph contains a path, the image is only shown while editing that specific glyph.

In font window ›Show Image‹ always shows all images.
Even if a glyph contains image and path:

›Show Image‹ _dis_abled still shows images in glyphs if they do not contain a path (like ›Show Image‹ _en_abled in edit windows).

The behavior is fine, my problem is, that the view doesn’t get updated properly (as described in the initial post).

I use the images as a template to trace handwriting.
In font window I want to have an overview of the completed glyphs. I’m not interested in the scans of the handwriting. In this case they only clutter the view.

In edit window(s) I want the images to be visible for tracing.

For me it would also be fine, if the behavior would be the same as in edit windows.
Then I would work with ›Show Images‹ enabled all the time (I don’t mind a few images, where I still need to do the path).

Sorry, this was not a suggestion to change anything. It was thought as an explanation, why I would prefer to have independent settings for font and edit windows.

Why not use a shortcut for turning the setting on and off?

Of course this would help (a little).

But it does not solve the main problem:
The display of font window is not updated when changing the setting.
I have to switch tabs, to get an updated view:
Glyphs–Show-Image.mp4.zip (300.2 KB)

For now I made a Keyboard Maestro Macro to do this, but this is just an ugly workaround.

Edit: I fixed it.

This works great in Version 2.3b (837).
Thank You!

I’m a new Glyphs user, but I seem to be experiencing the same issue here — I’m using an image to trace a central line, and in the font viewer I’d like to be able to just see this line, as I can with c and d (unless I’ve drawn closed paths as per characters a and b), whereas I’ve drawn the same line for e and f on a separate layer but the image is showing…

Any advice would be greatly appreciated…

ok — i think i’ve worked it out — I was using layers ‘backwards’ ! :speak_no_evil:

1 Like