"Don’t use Production Names" doesn't work properly when exporting TTF

This is in Glyphs 2.3b (856).

The custom parameter “Don’t use Production Names” works well when exporting OTF.

However, when exporting TTF (“Save as TTF”), there’re at lease two issues:

  1. Certain glyphs (so far I’ve encountered “CR”) always get production names, no matter if “Don’t use Production Names” is on, or its Unicode value is cleared, or its production name is manually set in the Option-Command-I sheet.

  2. For glyphs with custom names (seems to be any glyph name not in AGLFN?), if it has Unicode value assigned, it gets such an error: “Error with glyph: tmA (The glyph name is not valid or might be too long)”. This issue can be bypassed by removing the Unicode value from such a glyph.

Neither of above issues happen when exporting OTF.
Are they indeed bugs, or simply due to some limitation of TTF’s nature?

A minimal test case is attached: Test-Regular.glyphs.zip (1.5 KB)

For the TTF export, it did only look for the custom parameter in the instance (and not in the font). I fixed that. Thanks for the test font.

Ah! Thanks Georg, it’s nice to know the workaround, it works now.
The issue 1 (glyph name CR always being renamed to uni000D) I mentioned, though, still exists when I set the parameter to the instance. (While not happening when exporting OTF with “Don’t use Production Names”.)

Ah, btw, just in case you missed— the UseProductionNames parameter in GSInstance.generate() doesn’t work either (when Format='TTF').