Erode Plugin doesn't work


#1

I would like to use this plug-in called Erode, with no luck. I selected a bunch of paths, then applied some random values at the prompt but nothing actually happen after hitting Apply. I there something I have to take care of before using this? Thanks!


Install modules
#2

What version of Glyphs do you have?


#3

Version 2.4b (929)


#4

This is what the console split out:

10/20/16 5:24:31.951 PM Glyphs[365]: Failed to connect (distanceXField) outlet from (Erode) to (GSSteppingTextField): missing setter or instance variable
10/20/16 5:24:31.951 PM Glyphs[365]: Failed to connect (distanceYField) outlet from (Erode) to (GSSteppingTextField): missing setter or instance variable
10/20/16 5:24:31.951 PM Glyphs[365]: Failed to connect (offsetField) outlet from (Erode) to (GSSteppingTextField): missing setter or instance variable
10/20/16 5:24:31.951 PM Glyphs[365]: Could not connect action, target class Erode does not respond to -setOffset:
10/20/16 5:24:31.951 PM Glyphs[365]: Could not connect action, target class Erode does not respond to -setDistanceY:
10/20/16 5:24:31.951 PM Glyphs[365]: Could not connect action, target class Erode does not respond to -setDistanceX:


#5

Can you try removing and reinstalling the plugin? Then restart the app.


#6

Great, I just remove all plugins, reinstall Erode and works well, even it’s other ui…


#7

Hi All,
I’m also having a problem where the Erode plugin doesn’t work. I’ve tried removing/reinstalling/restarting app and it doesn’t seem to do anything when I input any values (have tried smaller and larger values to test) on any character (straight or round). I’m using Glyphs app Version 2.4.2 (1057). Thanks for any help.


#8

Perhaps @SimonC can chip in?


#9

That’s not my Erode plugin. Mine looks like this:


#10

That is strange. I wonder why mine looks the way it does? I installed it via the Glyphs PlugIn manager. Thanks for your reply, any thoughts about how to get yours to install or work properly? It seems like a great script that will be useful.


#11

I don’t know. I just tried it via the Glyphs Plugin manager myself, and I got the version I screenshotted. I suggest uninstalling and then going through your Library/Application Support/Glyphs/Plugins folder and making sure there’s no remnants there before installing again.


#12
  • Which version of Glyphs are you running? Make fire you have the latest one.
  • Look for any outdated plug-ins and delete them.

This is likely an incompatibility between plug-ins. There was an issue at one point where one would call another’s interface. Old plug-ins perhaps still trigger it.


#13

Thanks for your thoughts/suggestions @SimonC and @mekkablue . I’m using the latest, Version 2.4.2 (1057). I think it might be a case of old plugins/borrowed interfaces, as you said. I’ll go through and see if I can clean up and identify. UPDATE: It seems it was the Shadow plugin that it was conflicted with. I removed and Erode works now. Thanks!


#14

These plugins still misbehave, if you have Shadow installed, then Erode won’t work.


#15

I will have a look at Shadow, may take a few days though.


#16

I removed the Shadow filter, which it was conflicting with, and now it conflicts with the Rimmer…?


#17

Please update all your plug-ins-