Error adding licence


I had the trial version of Glyphs 2 installed on my mac and it expired, I purchased a licence today and tried adding it to the app but kept getting the “The Test Period has expired. Please visit to get a license.” message. I searched the forum for a solution and followed the steps that worked for some of the members but they didn’t work for me. I uninstalled the app and re-downloaded it, tried app zapper to remove all related files then re-installed, but non of that worked for me.

Any idea how to fix this issue?

Try the steps described in this tutorial:

Hi mekkablue and thank you for the reply.
I did follow the steps in that toturial and other posts on the forum as well but non of them solved the issue.

Did you restart the mac after deleting the preference files?

Yes I did.

I am having the same issue. I tried uninstalling the app several different ways. Nothing so far has worked. Is there someone that can help with this?

Did you follow the steps in the tutorial?

Yes, I did.

Please contact me via DM and schedule for a screensharing session.

I am having the same issue, i’ve restarted a bunch of times, removed the app and reinstalled several times, hunted down the other files and deleted what could be found… Just purchased the app since the trial expired. I completely love it - just eager to get to work! any help would be greatly appreciated

Did you read the tutorial? The one I posted the link of above.

Yes i’ve gone through the steps in the tutorial several times. Sorry to be a pain, I tried to resolve the issue without involving you but i just can’t seem to get it to license?
Again any help is greatly appreciated.

Can you send me the license file to support (at) (this website without www). I will have a look. It may be corrupted.

Any luck?
I sent the file that I recieved yesterday.
Sorry to be a pain, just wondering how to get it working and needing some support.
Again any help is appreciated

Thanks! Per your suggestion in email,i was able to log in as a different user and register it. Then when i went back to my original user it restarted and seemed to fire up just fine. Anyways Thanks! it seems to be working great.

1 Like