"Error at line 6148". My document wont open anymore

The problem is supposed to be the lastChange, but I have no idea how to fix it.
Please help.

glyphname = backslash;
kernLeft = "\";
kernRight = "\";
lastChange = "2023-05-15 12:24:40 +0000";
layers = (

Schermafbeelding 2023-05-15 om 15.03.02

There is something wrong with the kern values (kernLeft and kernRight). It should look like this:

glyphname = backslash;
kernLeft = "";
kernRight = "";
lastChange = "2023-05-15 12:24:40 +0000";
layers = (

Edit these two lines to remove the \ character. Or send us the file (private message here on the forum or an email to support) and we will send you the fixed file back.

The backslash \ is not a valid kerning group name. How did you manage to enter those?

Dont know, just did it. Apparently it worked for a bit and when I tried to restart Glyphs for a plugin the file didnt make get it

I sent you the file

I think Glyphs 2 was not properly validating the kerning groups.

Can be, I was grouping the kernings.

So what’s next, I don’t know anything about code or fixing this

Where did you send me the file? I’m sorry, but I cannot find it in the email inbox or in my private messages.

Open the file in a text editor (Sublime Text, for example). Go to the line number indicated, remove the \ and replace it with something like backslash. Save the file and re-open it in Glyphs.

If you want the technical explanation: the backslash is an escape character, meaning any character typed afterwards will be read as a string, so \" will not close the string. This is why the lines were not read properly.

Mailed it to you on forum@glyphsapp and support@glyphsapp. Its called Uncial

Sorry, I somehow missed it. I have send you a repaired version where I changed the two lines as described above.