Error Message/icon in Glyphs 3

Screen Shot 2021-03-02 at 18.27.58

Hi,
For the first time I’m seeing this error that I haven’t seen before in Glyphs 2 (maybe it existed). Unsure how to resolve it, but what is noticeable is that the regular weight is “imposed” on the bold weight as a copy - and I can’t seem to remove/delete/edit the regular “imposed copy” from the bold weight without making changes to the regular weight.

Thinking it’s a simple fix, anybody know how to resolve this?

Best,
/s

I don’t know about an imposed copy, but those two icons can be removed if that’s your goal. The one on the left is an Annotation (note) and the other is the Non-Export icon.

Open the glyph, select the Annotation tool (the balloon icon), click on the annotation that appears and hit Delete.

To remove the Non-Export icon, right click and set the glyph to Export. That can be done in the glyph window or the font view. In font view you an also set it in the panel at lower left for any selected glyph(s).

1 Like

In Edit view, a couple things consider regarding seeing both weights:

  • The eye icon in the layers palette (right side panel) for each layer may be open. Closing it (by clicking on the eye icon) may help.
    image
  • The Select All Layers tool may be selected. Click and hold on the icon to choose the Select_tool (or press Shift-V to cycle through the options.
    image
1 Like

Thank you both!
Not sure how I added annotations but they are gone now and the glyph is set back to export :slight_smile:

I had a sneaky feeling it was a silly “check-box error”.

— I love this forum!