Error when exporting a variable font (not the same as the previous topic)

Hi everyone,

I’m working on a variable font and it happens that a few glyphs aren’t exporting even though they should (I guess). I keep getting this message

I don’t have any point on an other one, I have the same number of nodes and points for every glyphs. I have no clue why it doesn’t work.

Can anyone help me, please ? This is rather urgent/important, it’s for my diploma project due in 10 days.

Thank you very much !


  1. Have you checked path order? (Filter > Fix Compatibility)
  2. Have you added Enforce Compatibility Check to Font Info > Font > Custom Parameters, so you can use View > Show Master Compatibility?
  3. If the outline changes a lot in one place (inflecting to non-inflecting), compatibility can be lost in TT conversion. In the most recent versions (1040 and later), you have to try pretty hard to trigger such a conversion error. Make sure you have the latest cutting edge version of Glyphs (Preferences > Updates).

Can you post a screenshot of your X outlines?

Thank you very much for your quick answer! Actually, for a random reason I tried just to “cmd + R” my shapes and it worked… No idea why. Here is what the X looks like :