Error when exporting variable font’s italic instances

Hi Glyphs hivemind!

I am designing my first variable font and loving all the possibilities! I’m encountering an issue when exporting, though. I’ve read through all the articles, forum posts, and handbook regarding variable fonts, and still can’t figure this out. I think I’m probably missing something really basic!

My font has 6 weights (Light through Black) and 6 italic versions of each, so I have 12 instances total. My italic instances all use the following Custom Paramenter filter: “Transformations;Slant:8;SlantCorrection:0;Origin:4;”.

See the attached screenshots below for all my Masters and Exports settings!

Everything is interpolating beautifully! I am able to export the 12 fonts as OTF files and they all work as expected.

When I try to export the Variable font, I receive this error: “The operation couldn’t be completed. Instance outside of the interpolation space: Light Italic”. If I deactivate Light Italic and try again, it tells me the issue is with Italic, etc, etc. If I deactivate all the italic instances, then the variable font exports and the Weight function works perfectly in Adobe.

So clearly my issue is with my italic settings and/or with the fact that I don’t understand how to set up a Variable Font Setting instance. Do I need a Variable Font Setting instance for each of my 12 instances? Do I just need one that somehow applies to all 12 fonts, roman and italic? I read something in another post about “chaining” to the italic version, but I can’t figure out what that means!

Thank you in advance for taking the time to answer. I don’t take product support like this for granted, so I am extremely grateful for the time you all spend answering newbies like me!

— Molly





That is normal.
Masters are used to create the Designspace of VaribleFont.
Actually with two masters you can only export a variable font with :
Light / Regular / Medium / Semibold / Bold / Black

If you want to export also Italic you need to create 2 additional masters :

  • Light Italic (Weight 100, Italic 1, Slant 1)
  • Black Italic (Weight , Italic 1, Slant 1) ( same as Weight value of your Black Master)

You can create master from Instance by selecting your export in Exports panel and click on “Instance as Master” from the (+) button.

Capture d’écran 2022-05-30 à 14.21.46

Hi Hugo,

Thank you! This partly helped, but still did not fix the issue. I created 2 new Masters for Light Italic and Black Italic, and added the values you said. As soon as I did this, I was able to export the variable font without errors. But the italics still aren’t working properly.

I think my confusion lies with the Variable Font Setting instance. I would ideally like to create my italics using a transformation parameter. How can I do this? I read that custom parameters of normal instances are lost during variable font exporting, so I have to add custom parameters to my Variable Font Setting instance. However, when I add my italic transformation parameter to the Variable Font Setting, the exported TTF is italic at 0 and moves to roman at 1.

Here are some screenshots:


Thanks you again!
Molly

Filters cannot be applied to variable font exports.

You need to design the masters properly in order for the variable font to work.

In your case, what you can do:
First, delete the “italic” masters that you added.
Click on an instance that has the italic filters.
At the bottom of the window, click the + button and click “Instance as Master”. This will add the instance as a master to your project.
Do this for the Light Italic and Black Italic instances.
Remember to add an Italic axis to your project in Font Info > Font.
Set the axis coordinate for your new Italic masters to something else than the Roman (upright) masters (1 or 100 are standards, but it doesn’t matter)

After making sure that the outlines look good to you, you can export the variable font.

To recap: the basic premise of a variable font is that you define an n-dimensional space, with n being the number of axes you want to use. You always need 2^n masters to describe this space – one master at each corner of the design space.

2 Likes

Thank you very much! This helps me understand the setup a lot better.

I’ve successfully designed multi-master fonts dozens of times in the past, so the master compatibility and setup part is much more familiar to me. So with your feedback, I easily created my italic masters with my italic versions of all the glyphs – no filters – and it’s exporting beautifully now. Thank you!

I can definitely pinpoint that my confusion lay in the “Variable Font Setting” instance. I admit that I’m still confused what that’s for, if it’s not for applying custom parameters, filters, etc. My variable font exports just fine without it, so I think I’ll leave it out for now. :slight_smile:

Thank you for taking a moment to help me! I’m still learning all the powerful things that can be done with this app, and having so much fun just playing around with it. I appreciate your help so much!

Molly

This is technically not the true. The technically required minimum is the origin and one master per axis. You might add an extra master at the forth corner to fix design issues.

There are still a lot settings you can apply with the “Variable Font Setting”. e.g. the family and file name. And replace/rename glyphs.

1 Like

Got it! Thank you. I will have fun playing around with all of this. I’m really pleased with my first variable font attempt. Now I can’t wait to go back to tweak some of my older fonts and re-publish them in variable format!