Error when exporting variable fonts

version: 2.43

version: 2.5b(1094)

Variable fonts can not be exported.
I tested it in two versions.

  1. Make sure you have the latest beta (currently 1095).
  2. Try to find out which glyph it is that does not export. (Turn off export for half the glyphs, see if it works, and so on…)

Often it is a path arrangement where a curve segments is inflecting in one master but not inflecting in another. Adding a node at the inflection point may help.

1 Like

If the latest cutting edge version can’t export the file, could you send it to us?

1 Like

I tried turn off export for half the glyphs, but the same problem occurred.
I understood that I had to add points to the steep parts like 'S’
There are many glyphs, so it is not easy to identify the cause.

I also tried the latest cutting edge version. I checked the master compatibility, but I did not know what the problem. I will send you a file. Thank you!

Hi guys,
I have the same problem here. I don’t have the 2.5 installed (only 2.4.4 1075) — is it necessary to update the OS to High Sierra to test the cutting edge 2.5?
If it’s needed I will, but I would prefer not to!
I’ll send you the .glyphs file by email.

Th cutting edge version has nothing to do with High Sierra. The system requirements didn’t change a bit.