Error with glyph

When i add User Parameters
“Name Table Entry” = FONTNAME;
also in the Instances like:
“Don’t use Production Names” = 1;
I get an
Error with glyph: uighurkirghizyehHamzaabove_alefMaksura-ar
on export.
Kicked that (“Don’t use Production Names” = 1;) out again, just wanted to mention.

It you don't use production names, the nice name is used an that is too long. Only 31 characters are allowed.

1 Like

How do i get full control on the attribut „Fontfamily/Familienname”?
I would like to output a font without a -hiven or space, e.g. „FAMILYNAME-STYLENAME” but „FAMILYNAME_STYLENAME” connected through an _underscore.

table name {
nameid 0 1 “Copyright, © 2017 …”;
nameid 0 3 1 1033 “Copyright, © …”;
nameid 1 1 “FAMILYNAME”;
nameid 1 3 1 1033 “FAMILYNAME STYLENAME”;
nameid 2 1 “FAMILYNAME”;
nameid 2 3 1 1033 “Regular”;
nameid 4 3 1 1033 “FAMILYNAME STYLENAME”;
nameid 5 1 “Version 1.001”;
nameid 5 3 1 1033 “Version 1.001”;
nameid 9 1 “DESIGNER”;
nameid 9 3 1 1033 “DESIGNER”;
nameid 10 1 “Copyright © 2010 …”;
nameid 10 3 1 1033 “Copyright © 2010 …”;
nameid 13 1 “Copyright \A9 2017 …”;
nameid 13 3 1 1033 “Copyright \00A9 2017 …”;
} name;

I don’t know what to add in the Instances or elsewhere to get a result in the nameid, like compatibleFullName = “FAMILYNAME_STYLENAME” which replaces the blank with an underscore.
Could you again give me a hint? I recon this should be an easy task, but i am stuck here. Thanks a lot.

Something like User-Parameter familyName for the familyANDstyleName.

You can set it with a name table entry parameter. Documentation in the handbook appendix.

Not sure this is a good idea though. Why do you need to use an underscore?

Unfortunately “Name Table Entry” = “FAMILYNAME_STYLENAME”; as well as compatibleFullName = “FAMILYNAME_STYLENAME”; didn’t work for me. still the file name is FAMILYNAME-STYLENAME and the full name is FAMILYNAME STYLENAME. What am I doing wrong?

The file needs to have that certain naming, because it is demanded by the programming that refers to that font – no space and no hiven supported yet.

For Name Table Entry you need to add the name/language/encoding ID. Please check the handbook.

The syntax is wrong. Please read the description of Name Table Entry in the Appendix of the Handbook.

Sorry guys, couldn’t find it in the Glyphs-Handbuch-2014.pdf. Now the Glyphs-Handbook-2.3.pdf offers this information on Name Table Entry on p.190. Since i am not a programmer, i don’t know how to make use of that information < nameID >; (without the blanks). I guess that i need to program a string to change the name of the font to my liking, something like: < nameID >“FONTNAME”;< /nameID > am I getting closer here?

“Name Table Entry” = “4;FONTNAME_STYLENAME”; got the desired result on the complete name info section. How ever “Name Table Entry” = “5;1.001”; to change the Vers. # individually doesn’t seem to work.

Use the longer syntax with the four numbers.

What Georg said, or simply use the versionString parameter. Some name table entries have a separate parameter.

versionString = “1.001”; worked like a charm, thanks @mekkablue