Everytime I open Glyphs, it asks for the license again


#1

Hello,

I was using the 30-days trial Glyphs App and when it expired it started to ask me for the full license.
I purchased a Glyphs 2 License and everytime I open Glyphs it asks me to put the license once again, and it’s quite annoying. How can I solve this so I only have to put the license once?

(Note: I even got a second license via mail, but it did not work also.
I followed this tutorial, but it still didn’t work.
https://glyphsapp.com/tutorials/how-to-install-your-glyphs-license )

Thanks again :slight_smile:


#2

Did you try all the steps including the Terminal command?

If so, please schedule for a screen sharing session.


#3

Hello Mekkablue,

I could not try terminal until today, sorry. And still does not work… So annoying.
When I do the Terminal thing it says.

2018-12-03 09:45:17.508 Glyphs[1573:47119] Failed to connect (exportPrefsPanel) outlet from (GSMenu) to (UKPrefsPanel): missing setter or instance variable
2018-12-03 09:45:17.528 Glyphs[1573:47119] JSTalk listening on port com.GeorgSeifert.Glyphs2.JSTalk

So this looks like it’s not working. Any suggestions?

EDIT:
I just re-installed the Glyphs another time and looked in the “Registration” panel. It says my Registration is from Glíglifo (a type design course I took a year ago) where we used Workshop Licenses. Is there any way to un-register this and put my license?

Thanks,
Miquel.


#4

To unregister, delete Preferences file at ~/Library/Preferences/ByHost/com.GeorgSeifert.Glyphs2.[A lot numbers].plist.


#5

Or simply double click the full license. It should overwrite the temporary workshop license.

And the License Tutorial is updated.


#6

It did not work until I did both things (unregister from preferences, and double-clicking at the license) and restarted the PC. It did not work just by “double-clicking the full license”.

Sorry for the unconvenience, and thanks. :slight_smile: