Excel weird behaviour


I’ve a client who is getting some problems with text (horizontal) alignment in Excel (Mac).

I’m not able to test it on the Excel version he’s using, however I did my tests on other Mac and Windows Excel versions and it just works fine for me.

This is the screenshot he sent me.

Since the Font Metrics are the same for the entire character set, I don’t understand how can this happen just on accented letters.

Has anyone experienced this before? Any solution?

1 Like

Very likely a cache problem.

And if the the problem remains after cleaning the font cache?

Can you send me the .glyphs file?

I’m still trying to fix it with the client, because it works fine for me. And now I’m testing on very recent excel version (similar to clients version).

So maybe he didn’t cleaned cache properly, idk :roll_eyes:

I will send it to you if I can’t solve this mystery. Thanks

IIRC Office on Mac had its own (kind of) font caching, too. But it has been a while. So only reliable way may be to rename the Family Name each time.

1 Like

I did that and that’s why I’m confused. It works fine on every Excel version I’m testing and it still goes wrong for him :rage:

He did the " Restart your Mac while holding down your Shift key to clean font cache. Do you think he can get a better result with Make Apple Type Server clean its database or with FontNuke for example?

To make sure to avoid font cache issues: Change the font name to something totally different, like “TestFontXYZ”. Add an obvious shape to the “Udieresis” glyph. Check if the shape is on the screenshot.

1 Like

Hi, @FranciscoTorres!
We are facing the same problem here, it’s not a problem of cache but how the font renders in Excel.
Using TTF the text gets misaligned, but using an OTF version is working OK.
Did you manage to solve the problem?

Thanks a lot

Hi @juandelperal . Thanks for the feedback. I think i tried both (OTF & TTF) at the time, but it was a strange problem from the client machine I could not understand. I tried different ways to fix it but I didn’t find the solution.
And everything was fine on my Mac and PC tests so I could not reproduce it.

Thanks anyway