Export an OTF family problem


I am using the free trial version of the latest Glyphs app, and I seem to be having problems exporting a type family. The Font info is all ok. The family (lets call it NAME has 5 weights - light, regular, medium, bold, black). When I export the family and import it to FontExplorerX I already notice a problem … the software does not group it as a family (NAME + 5 different weights) but displays it as 5 different fonts (NAME Light, NAME Regular …), an when I try to use it in Adobes apps’s only on weight shows up and it is named NAME Black (family menu) Regular (weight menu).

This family is defined from 3 masters, and I have defined 5 instances

I dont get it! I think I should use some custom parameters, but I cant figure it out which one …

Can you help?

There are no custom parameters involved. If the instances are set up correctly, it should work.

Can you send me the glyphs file that I can have a look?


thank you very much for your response.

I would not like to be sending the glyphs file around, only in the case of not being able to resolve it through screenshots and similar. And I also think that screenshots would benefit others as there is no detailed manual for glyphs. I know a couple of people, that switched back to FL just because of this problem.

So I will post the screenshots here, if they do not help, then I can send the file.

I hope you understand!

Thank you again

Light ; Regular ; Medium ; Bold ; Black

The settings in the screeshots look good. Only the linked style in the bold is not necessary.

How does the font info page look?

And what version of Glyphs do you have?

Ok, I have removed the linked style

I am adding the font info, masters and Open type def. screenshots

Version: 1.3.7

They look fine, too. So there is nothing I can do without having a look at the file. I will delete it immediately after I have review it.

(Why do you write the feature code for small caps and numbers yourself?)

The feature code for small caps (and for everything else) was done before, and when I was trying out Glyphs I migrated it on my own, and also it is a bit different from the way it is normally done - I put a little twist of my own on it … different reasons

Sure, in this case I will send the file, and as you said - please delete it afterwards … could you give me your email?

info [at] + the domain of this site.

Problem solved

Georg Seifert was so kind to check out my font file and discover that there were no faults in the font by it self. In the process of doing this he sent me a couple of good advices on my development and coding process which will come in handy, so I thank him again for that.

As to the source of the problem:

He advised to always install fonts in to the Adobe font folder /Library/Application Support/Adobe/Fonts/

I did this and the font family worked fine, so the source of the problem was Font Explorer X which I would not like to let go, as it is a great app for managing fonts!

So next step was to clear all the system and app font caches which I did in the next three ways:

  1. Font Explorer X: Tools/Clear System Font Folders … - tick the clear cache box and press clean

  2. Terminal: Open terminal and enter and execute the following command one by one (without quotes): “atsutil databases -removeUser”, “atsutil databases -shutdown”, atsutil databases -ping"

  3. Download “Font Finagler.app” from http://homepage.mac.com/mdouma46/fontfinagler/ open it, select custom, tick all the options and press ok - when it finishes, it will restart you’re machine

So this three steps did the job for me and now everything works fine
As this problem showed itself the first time with glyphs, and I know people with the same problem I decided to post the solution

I thank the GlyphApp team again for their help!

hello guys,
i just bought glyphs but can`t export the font. i modified an installed font - and now can not export it. i am using Version 1.3.8 (350) at Mac OS X 10.6.8.

the export report says (german):
cmap{plat=3,script=1,lang=0}: multiple glyphs Omega uni03A9 mapped to code <3a9>
Es wurde keine Datei generiert.

no idea what this means but i really need this font as otf!
i appreciate any hints!

This is a common problem. Delete the glyph “uni03A9”. There will be some more of this error messages. Please read it (the two names are next to “multiple glyphs”) and delete one of the glyphs, they are duplicates.

I improved the import to avoid this problem.

alright, it works now. thanks a lot!